Algorithme et Programmation

Algorithme et Programmation

Notre professeur de Sciences de l'ingénieur vous propose de réviser la méthode pour créer un algorithme et pour programmer le plus efficacement possible. Cette leçon est au programme de la terminale scientifique et vous sera utile dans votre...

Document rédigé par un prof Algorithme et Programmation
Télécharger gratuitement

16.00/20

4.0000 5 0

1 Avis > Donne ton avis

4355 téléchargements

Le contenu du document

Notre professeur de Sciences de l'ingénieur vous propose de réviser la méthode pour créer un algorithme et pour programmer le plus efficacement possible. Cette leçon est au programme de la terminale scientifique et vous sera utile dans votre épreuve du Bac scientifique !

I - Définition 

Ensemble de règles opératoires rigoureuses, ordonnant à un processeur d'exécuter dans un ordre déterminé un nombre fini d'opérations. Il nécessite donc une programmation stricte et structurée.

II - Représentation graphique :

1 - Définition 

La représentation graphique de l'algorithme est appelée organigramme.

2 - Symboles utilisés 

3 - Organisation d'un algorithme :

L'en-tête : nomination de l'algorithme et définition du traitement effectué et des données utiles.
La partie déclarative : description des différents objets que l'algorithme utilise.
Les constantes : « objets » constants (exemple : (Pi)= 3,1416.
Les variables : « objets » dont la valeur change. (Exemple : les nombres réels)
La partie exécutive : délimitée par les mots début/fin.
Les commentaires : données insérées dans le programme pour faciliter la lecture.
Le renvoi : symbole utilisé deux fois pour assurer la continuité lorsqu'une partie de la ligne de liaison n'est pas représentée.

4 - Les actions de base 

1 - L'affectation 

C'est l'action essentielle de l'algorithme. Elle attribue une valeur (constante) à une variable. Son symbole est « <- » (Exemple : valeur_initiale <- 10)

2 - La saisie ou l'écriture d'une valeur 

LIRE ()
ECRIRE ()

5 - Les structures alternatives 

1 - Les structures alternatives de base 

Si condition
ALORS action 1
SINON action 2
Fin si
Remarque: Si action 2 inexistante alors on a:
Si condition
ALORS action 1
SINON rien
Fin si

2 - Les structures alternatives imbriquées 

Si condition 1
ALORS
Si condition 2
ALORS action 1
SINON action 2
Fin si
SINON
Si condition 3
ALORS action 3
SINON action 4
Fin si

3 - Les structures de choix multiples 

SELON condition
Cas 1 : action 1
Cas 2 : action 2
Cas 3 : action 3
Fin si

6 - Les structures itératives ou répétitives 

1 - Définition 

Elles permettent d'exécuter plusieurs fois une séquence d'instructions.

2 - La boucle POUR : boucle de comptage

Initialiser i
POUR i (variant de valeur_initiale jusqu'à valeur_finale)
Actions
Fin pour

3 - La boucle REPETER :

REPETER
action 1
TANT QUE condition

4 - La boucle TANT QUE...FAIRE 

TANT QUE condition
FAIRE action 1
Fin TANT QUE

 

 

Retrouvez d'autres cours de Sciences de l'ingénieur en cliquant sur le lien.

Fin de l'extrait

Vous devez être connecté pour pouvoir lire la suite

Télécharger ce document gratuitement

Les avis sur ce document

Xalis1
4 5 0
16/20

Bonne introduction de ces notions mais pas assez exhaustive puisqu'elle ne traite que des organigrammes. C'est un début.

par - le 12/10/2014

Donne ton avis !

Rédige ton avis

Votre commentaire est en attente de validation. Il s'affichera dès qu'un membre de Bac S le validera.
Attention, les commentaires doivent avoir un minimum de 50 caractères !
Vous devez donner une note pour valider votre avis.

Nos infos récentes du Bac S

Communauté au top !

Vous devez être membre de digiSchool bac S

Pas encore inscrit ?

Ou identifiez-vous :

Mot de passe oublié ?